AS Route Map Problem

Is anyone else having trouble updating their airline on AS Route Map? It seems to have wiped my route map, and just focusses on a random spot in the Pacific Ocean…I have now tried a number of times, as well as re-created the map, but with no success.


I do have the same issue. When selecting another airline everything is OK, but not when showing my own.

Yeah! Exactly the same! I can see everyone elses routemap but mine!

I guess that was a failure due to its own success. The table with the flight numbers has outgrown the integer type of its key. It got stuck at 2147483647 and couldn’t add anymore flight numbers.

After changing the type to BIGINT (which can hold up to 2^63 - 1) it works again.

1 Like

Remember to donate to this guy! Awesome tool for us playing AirlineSim :clap:


Seems that it workd fine now, but when trying to update my airline, something breaks. This is the only response I get from the update function.

Beginning with importing flightplan
Start reading flight plan

Flight plan page with 0 bytes read
Existing flight plan deleted
Import of flight plan skipped, as no data found
Import completed

View this airline

Any help?


1 Like

It looks like the problem is based on the requirement for TLS1.2 as a minimum standard on some game worlds (Domination and others). My old tech server seems to struggle with the TLS1.2 standard and therefore can’t fetch the flight plans anymore.

@Matt, maybe that can help?

1 Like

@Matth If you need a newer server, I could certaintly spin up a Windows 2019 or some kind of Linux server for you. Just give me a shout out.

1 Like

I fear I don’t have good news. After digging into this a bit more, it looks quite tricky.

As a simple fix I asked Martin whether he would “downgrade” his servers, but not surprisingly, he doesn’t want to do that.

While it seems that my server (Windows 2012 R2) does support TLS1.2, it seems to fail cos of the missing ciphers. According to Microsoft, Windows 2012 R2 does support the following ciphers ( When testing my function, I do get the following back:

{"given_cipher_suites": ["TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384" ,"TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256" ,"TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA" ,"TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA" ,"TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384" ,"TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256" ,"TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384" ,"TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256" ,"TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA" ,"TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA" ,"TLS_RSA_WITH_AES_256_GCM_SHA384" ,"TLS_RSA_WITH_AES_128_GCM_SHA256" ,"TLS_RSA_WITH_AES_256_CBC_SHA256" ,"TLS_RSA_WITH_AES_128_CBC_SHA256" ,"TLS_RSA_WITH_AES_256_CBC_SHA" ,"TLS_RSA_WITH_AES_128_CBC_SHA" ,"TLS_RSA_WITH_3DES_EDE_CBC_SHA"] ,"ephemeral_keys_supported":true,"session_ticket_supported":true,"tls_compression_supported":false,"unknown_cipher_suite_supported":false,"beast_vuln":false,"able_to_detect_n_minus_one_splitting":false,"insecure_cipher_suites":{} ,"tls_version":"TLS 1.2","rating":"Probably Okay"}

So, TLS 1.2 is “Probably Okay”. But the AS servers only support 3 ciphers for TLS 1.2, which are:

|# TLS 1.2 (suites in server-preferred order)|
|TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256 ( `0xcca8` )   ECDH x25519 (eq. 3072 bits RSA)   FS|256|
|TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 ( `0xc030` )   ECDH x25519 (eq. 3072 bits RSA)   FS|256|
|TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 ( `0xc02f` )   ECDH x25519 (eq. 3072 bits RSA)   FS|128|

So, since mine and AS’ server don’t support the same ciphers, they can’t talk with each other.

Now since my site is based on ASP classic, I’m not even sure whether a migration to a newer OS would solve the problem. The components used are quite old and Microsoft is not supporting ASP classic anymore, as far as I believe. So it looks like a big(ger) migration might be required, or more like a complete re-write…

I will continue to look for a solution, but don’t just yet be too optimistic.

UPDATE: I just tested the necessary function on a Windows 10 machine that does have the cipher TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 to check whether I could retrieve the page there. Unfortunately, the same problem persists.

1 Like

@ matth… by the way.

did u have a “automatic airline update routine” running on ure side?. if yes, maybe u can deactivate that as long the problem is? so some player could work with there last update.

1 Like

It’s all gone a bit technical for me, however I thought it’d be handy to just say my routemap is working again!

Thanks for all the suggestions and offers. After investing another day and configuring a Linux server with various ciphers, some more googling and trial and error, I finally came across a post that explained how to prioritize and enable specific ciphers in Windows.

After trying to find a suitable and safe cipher that both works in TLS 1.2 and Windows Martin was so kind to amend the settings on his servers. So it should be working again on all worlds. Let me know if something is still off.

Some airlines might have gotten erased in between, so just update those again and it should show again.


@Matth Thank you again for continuing to support this awesome project. I made another donation today to support your costs.

1 Like

Seems I’m late on this, there’s an utility called IIS Crypto that helps sorting out TLS/Ciphers maybe it helps out in the future.

1 Like

I have received the link to that from another player already. That one didn’t help, but I found a solution. But thanks.

1 Like

I have a problem creating a new airline (71658) map on Tempelhof.
Updating existing airline went smoothly.

Error message in german:
Laufzeitfehler in Microsoft VBScript Fehler "800a0006’

Überlauf: ‘CInt’

/create.asp, Zeile 90

Matth added an inputcheck but obviously not considered the limit of CInt of 32767 :wink:

he just need to change it to CLng i guess

Exactly as Robert said. It’s fixed.

Merry Christmas!


Hi, I was a big fan of route map when I was playing few years ago. I am back again.

I tried to get it the route map for my airline however it does not seem to work. Do we have issues with this or is this still working?