On Board Service - In the Red


Just started playing and establishing a few routes. Playing on Meigs.

Have a question - i have reset my cabin configuration on some of my planes CRJ1000 and Dash-8 400As.

I have increased the seat sizes for the business class. Then i went and modified the in flight goodies.

However when i look at the Flight Rating "Product Factors" i get green bars for everything but the On Board Service…

I cannot for the life of me figure out why its not a positive result, since i have green for price, seats, terminals etc… etc…

Any help would be greatly appreciated.



Do you have already created you On Board Service ? In the same folder where you can create your Seating there is another one to create on board Service. You will need at least 3 Service Profiles. On you can use on flight between 0-800km, one for flights between 800-1500km and one for flights with more than 1500km… then you need you asign one of the Service Menues to your flights. And then your on Board service should get better. If you have done this already you might increase your service level …

Wow I feel silly now…only 2 of my routes have services assigned.

No wonder nobody wants to fly with me :(

Thank you very much for the help…now to figure out how to update the routes. I go to the bottom an it has the Sevice listed there but does not list my three types Short/Medium/Long.

Ahh I will just delete the routes and start over.

Again thanks much for the pointer !!


That sounds strange - in the red outlined box under "service profile" there should be a drop down list

Try as I might there is nothing in the drop down menu. I went and reset my in flight stuff…made the 800km the default. But when i go to the route screen and try and change it from there nothing shows up.

The only way i have been able to make it work is to include the specific service setting when creating the schedule. Perhaps a bug? Or is it me not knowing what I am doing…


Go to Route Management and at the very bottom you will see this box:



From there you can change the on-board settings for the route.

Keep in mind, that from there, you can only select on-board service profile which complies with the route length requirements - if the route is 600 km long, you won’t be able to set a profile which requires 1.500 km and etc. In this case, only the visible route profile will be seen.

Whereas when creating schedule you can pick ‘any’ service profile. It’s not a bug or a cheat, because a non-compliant on-board profile will not be applied from there either.

I totally understand this now.

I had foolishly set "warm meals" and other things in the profiles and got 800km min restrictions for my basic service, then my medium service was 800km and long range was 1500km.

I was not getting any options as the routes were less than 800km

Thank you everyone for your help !!!