Airport screen lockups?

Recently the javascript rendering the airport maps has been locking up my browser has anyone else seen this?

I got the same i think since an update of firefox. I thought it was a fault of mine…

Using Fiorefox but don’t have problems with it.

I’m having the same problem as well, it’s happened since I updated firefox.

I had the same problem about 2-3 month ago using Firefox. I tried to hotfix the problem by blocking the graphics with AdBlock Plus, but it had no effect, as firefox seems to render the map anyhow. So later I contacted the support via chat and noone else experienced the problem at this time. In the moment we started to figure out, what causes the problem, it vanished. So we never came up with a proper solution to it. Looking back I would advise you to clear your browser cache, as it seems to be a temporary problem.

Hi there,

Having the same problem here. Using Firefox as well. I tried a lot option to fix this, but no luck so far.

I have a suspicion, but may be the developer team can comment. The airport map on the airport page has been added recently - if you look at the sourcecode (Firefox - tools - web developer - page source) you’ll see that the map is generated from a script - for larger airports this can be quite large, 100’s of lines of javascript code, depending on how many taxiways etc.

And what is the specific suspicion?

that it just eats up resources like crazy… hey, who’s the developer here?

ok, got the point - that’s a possibility.

Firefox brings a message -

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.


That sounds fairly conclusive to me.

Any chance of this getting fixed?

When will this be fixed? Everytime i open an airport page Firefox just freezes for some seconds! This is known for almost two months now!

Maybe the simplest solution: make it an option in the settings to display those pictures, i want to hide them!

The airport maps have been removed now. We wanted to sunset it anyhow.